Our engineering team has been monitoring system performance and has not seen further errors since the improvements were rolled out.
Posted Jul 02, 2026 - 15:33 EDT
Update
Our engineers have released the final improvements and we see the system speed returning to normal. We will continue to monitor over the next day.
Posted Jul 02, 2026 - 01:03 EDT
Monitoring
Our engineering team have released some improvements and we are starting to see the system recover. We are continuing to monitor system health.
Posted Jul 02, 2026 - 00:29 EDT
Identified
Engineering has identified root cause to the system slowness and should have a resolution very soon
Posted Jul 02, 2026 - 00:02 EDT
Investigating
Our engineering team is aware of degraded performance in the current report of Mariana Tek's Admin pages and Apps. Engineering is actively investigating.
Posted Jul 01, 2026 - 21:47 EDT
This incident affected: Applications (Admin, Biz App, Android Mobile App, iOS Mobile App, Web Integrations).